Soft shadows not working? - AGameTech forum
Меню сайта


Форма входа


Поиск


Мини-чат


Друзья сайта


Статистика


Приветствую Вас, Гость · RSS 20-Июн-2018, 15:51
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 1
  • 1
AGameTech forum » Проекты » Аshаdоw » Soft shadows not working?
Soft shadows not working?
dubzillaДата: Среда, 01-Дек-2010, 00:28 | Сообщение # 1
Новоприбывший
Группа: пришелец
Сообщений: 5
Статус: Offline
Hello, I have the new version, but soft shadows are not working, am i doing something wrong?
example:
Code

Include "..\AShadowBBinclude\fps.bb"
Include "..\AShadowBBinclude\Ashadow.bb"
SoftStencilShadows=1
aGraphics3D 640,480,32,2
SetBuffer BackBuffer()

camera=CreateCamera()
PositionEntity camera,0,25,30

light=CreateLight(1)
SetSLight(light,1)
RotateEntity light,45,45,0

EnableSoftStencilShadows (0.002, 5, 500)

Cube=CreateCube(0)
CreateCaster(Cube)
PositionEntity Cube,0,10,0
ScaleEntity Cube,5,5,5

cube2=CreateCube()
EntityColor cube2,100,200,150
ScaleEntity cube2,50,2,50

While Not KeyHit(1)

  TurnEntity Cube,1,1,0
  PointEntity camera,cube
   
  ARenderWorld(camera)

  Text 5,5,"FPS: "+FPS(50) ; draw fps
  Text 5,20,"ShadowTris: "+ShadowTris ; draw count tris in shadow volumes
  Text 5,30,"RenderTris: "+RenderTris; draw count tris in scene
  Text 5,40,"TimeShadow: "+TimeShadow; draw time for building shadow volumes

Flip 1
Wend
End

What am I doing wrong or is my pc not good enough? sad
 
Alexx_GromДата: Суббота, 29-Янв-2011, 15:42 | Сообщение # 2
Новенький
Группа: пришелец
Сообщений: 11
Статус: Offline
Hello, can answer late already, but such EnableSoftStencilShadows (0.002, 5, 500) a command in library isn't present.

It isn't present as in the description to library in file: "!!! AShadow_HELP (RUS) !!!.doc"

Than the smog has explained. Without command EnableSoftStencilShadows (0.002, 5, 500) this example works.

P.S.

Has found such function:

EntitySoftSelfShading ( Entity, Mode% )
0 - set from global SoftSelfShading mode (default)
1 - force enabling
2 - force disabling

thus it is necessary to specify by a call of remaining functions parameter SoftSelfShadingMODE=1, for example:
CreateCaster (mesh,files$=0,StencilS_range=0,on=1,S_MeshAlpha#=1, SoftSelfShadingMODE=1, ZfailOFF=0).

Сообщение отредактировал Alexx_Grom - Суббота, 29-Янв-2011, 18:55
 
ANDREYmanДата: Пятница, 04-Фев-2011, 13:58 | Сообщение # 3
Admin
Группа: Хозяин
Сообщений: 155
Статус: Offline
Hi!

Quote (dubzilla)
am i doing something wrong?

Yes (:

soft shadows only work in Fake mode (with PostProcess_Render )

try this:

Code


Include "..\AShadowBBinclude\fps.bb"   
Include "..\AShadowBBinclude\Ashadow.bb"   
;SoftStencilShadows=1   
aGraphics3D 640,480,32,2   
SetBuffer BackBuffer()

PostProcessInit()   

camera=CreateCamera()   
PositionEntity camera,0,25,30   

light=CreateLight(1)   
SetSLight(light,1)   
RotateEntity light,35,25,0   

EnableSoftStencilShadows (0.002, 5, 50)  ; customize far plane for optimal shadow bluring

Cube=CreateCube(0)   
CreateCaster(Cube)   
PositionEntity Cube,0,10,0   
ScaleEntity Cube,5,5,5   

cube2=CreateCube()   
EntityColor cube2,100,200,150   
ScaleEntity cube2,50,2,50   

While Not KeyHit(1)   

    TurnEntity Cube,1,1,0   
    PointEntity camera,cube   
       
    ARenderWorld(camera,1, 0.7)   
    PostProcess_Render(camera)

    Text 5,5,"FPS: "+FPS(50) ; draw fps   
    Text 5,20,"ShadowTris: "+ShadowTris ; draw count tris in shadow volumes   
    Text 5,30,"RenderTris: "+RenderTris; draw count tris in scene   
    Text 5,40,"TimeShadow: "+TimeShadow; draw time for building shadow volumes   

Flip 1   
Wend   
End   
 
dubzillaДата: Суббота, 12-Фев-2011, 16:24 | Сообщение # 4
Новоприбывший
Группа: пришелец
Сообщений: 5
Статус: Offline
Thank you! Now it's working!
But i ran into a problem, the 2d sprites with alpha seem to be affected with shadows.

Look at the picture:
http://img130.imageshack.us/img130/5746/bmwashadow.jpg

I tried to disable shadow receiving but nothing changed sad

 
ANDREYmanДата: Воскресенье, 13-Фев-2011, 05:15 | Сообщение # 5
Admin
Группа: Хозяин
Сообщений: 155
Статус: Offline
All 2d sprites and other alpha-blend objects must be sets to receivers for correct render.
to simplify - attach the 2d sprites to one pivot and set it as receiver 0

Code
global Global_Alpha_Pivot = CreatePivot()
CreateReceiver Global_Alpha_Pivot,0

EntityParent 2dSprite, Global_Alpha_Pivot  
EntityParent alphaBlendGeometry, Global_Alpha_Pivot
....
 
dubzillaДата: Воскресенье, 13-Фев-2011, 23:44 | Сообщение # 6
Новоприбывший
Группа: пришелец
Сообщений: 5
Статус: Offline
hmm do i need to atatch every single alphachaneled thing to work? even fonts?
Because i did what you say'd and now my car is white and no shadows and no hud biggrin

http://img402.imageshack.us/img402/1761/strangerl.jpg

 
ЯковДата: Понедельник, 07-Мар-2011, 12:50 | Сообщение # 7
Новоприбывший
Группа: пришелец
Сообщений: 5
Статус: Offline
Никак не работают у меня такие тени. Говорит функция EnableSoftStencilShadows
не найдена. sad
 
ANDREYmanДата: Вторник, 08-Мар-2011, 02:34 | Сообщение # 8
Admin
Группа: Хозяин
Сообщений: 155
Статус: Offline
Quote
http://img402.imageshack.us/img402/1761/strangerl.jpg

wacko

Яков, положи длл в юзерлибс и в папку с проектом. Ту длл которая в последнем архиве. Удостоверься что и там и там именна та длл.

 
ЯковДата: Понедельник, 11-Июл-2011, 20:51 | Сообщение # 9
Новоприбывший
Группа: пришелец
Сообщений: 5
Статус: Offline
СПАСИБО ХОЗЯИН cool
 
AGameTech forum » Проекты » Аshаdоw » Soft shadows not working?
  • Страница 1 из 1
  • 1
Поиск: